Linux Android emulator and KVM Opengl problems

Linux Android emulator and KVM Opengl problems

If you want to try to accelerate the Linux Android emulator through KVM, and you see errors like these…

Failed to load libOpenglRender.so
Failed to load libEGL_translator.so
error libEGL_translator.so: cannot open shared object file: No such file or directory
Failed to open libEGL_translator.so
Failed to init_egl_dispatch
emulator: ERROR: OpenGLES initialization failed!
emulator: ERROR: OpenGLES emulation library could not be initialized!
emulator: WARNING: Could not initialize OpenglES emulation, using software renderer.
Failed to load libGLES_CM_translator.so
error libGLES_CM_translator.so: cannot open shared object file: No such file or directory
Failed to init_gl_dispatch
Failed to load libGLES_V2_translator.so
error libGLES_V2_translator.so: cannot open shared object file: No such file or directory
Failed to load libGLES_V2_translator.so
error libGLES_V2_translator.so: cannot open shared object file: No such file or directory
could not find ifaces for GLES 2.0

In my case, i use Debian Testing and Android Studio. These files are located in Android Studio SDK folder: ~/android-studio/sdk/tools/lib/

To solve that errors, i simply created a symbolic link to /usr/lib/

sudo ln -s ~/android-studio/sdk/tools/lib/libOpenglRender.so /usr/lib/
sudo ln -s ~/android-studio/sdk/tools/lib/libEGL_translator.so /usr/lib/
sudo ln -s ~/android-studio/sdk/tools/lib/libGLES_CM_translator.so /usr/lib/
sudo ln -s ~/android-studio/sdk/tools/lib/libGLES_V2_translator.so /usr/lib/

And that’s all!🙂

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s